My StandPro Shows "Stripe Terminal Not Found"
Your Nizam stand and Stripe terminal are two separate devices. It's possible that the stand is charged and functioning, but the reader is out of battery or malfunctioning.
Common Causes
- The reader's battery is completely drained.
- The reader is not connected properly to the stand.
- The reader needs to be rebooted.
How to Fix It
- Try restarting the reader by holding down the ON button (on the side of the reader) for 10-15 seconds until the 4 lights begin flashing green.
- Check the power connection by ensuring the reader is securely plugged into the appropriate outlet on the Stand Pro. Verify the Stand Pro charging cable and adapter are properly connected.
- Charge the reader by leaving it connected to the plugged in Stand Pro for at least 15–30 minutes. If the stand has been off for a long time, both the stand and reader may need extra time to recharge.
- As a last resort, there is a pinhole on the backside of the reader next to the charging port. Insert a pin and hold down to reset the reader.
Why This Matters
The Stand Pro and Stripe reader have long battery lives, but still require occasional charging, especially after long periods of disuse. If the reader still won’t power on after charging and holding the power button, please contact Nizam Customer Support (salaam@nizam.co) for further troubleshooting or a potential hardware replacement.